Appsheet (Nieuwe Artikelen - Nouveaux articles) down

Incident Report for Cras

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 15:34 CEST

Identified

The issue has been identified and we are waiting on Google to make the service available again.
Posted Apr 15, 2025 - 10:51 CEST
This incident affected: Appsheet.