Update 03/10/2025 11:28*: The fiber cut was repaired at 11:15 and connectivity has been restored. We are waiting for confirmation that the incident has been fully resolved. If you’re still experiencing issues, please try toggling airplane mode on and off, or reboot your device.
Posted Oct 03, 2025 - 11:56 CEST
Update
Update 03/10/2025 11:28*: The fiber cut was repaired at 11:15 and connectivity has been restored. We are waiting for confirmation that the incident has been fully resolved. If you’re still experiencing issues, please try toggling airplane mode on and off, or reboot your device.
Posted Oct 03, 2025 - 11:47 CEST
Monitoring
Update 03/10/2025 11:28*: The fiber cut was repaired at 11:15 and connectivity has been restored. We are waiting for confirmation that the incident has been fully resolved. If you’re still experiencing issues, please try toggling airplane mode on and off, or reboot your device.
Posted Oct 02, 2025 - 22:58 CEST
Update
We are continuing to investigate this issue.
Posted Oct 02, 2025 - 16:20 CEST
Investigating
Mobile outage: Calls, SMS & data affected in all areas.
We are currently experiencing an outage with our mobile services. Our Network Operations team is investigating this outage. Further updates will be released as soon as possible.
Please find all details below:
Start*: 02-10-2025 ~14:00 End*: Duration: TBC Impacted services: All mobile services (calls, SMS, data). 4G backup solutions via EDPNET Affected Areas**: All areas
Edit 14:35*: Our mobile services provider has confirmed that a fiber cut is affecting services. They are communicating with their service delivery teams and are looking for a solution.
Posted Oct 02, 2025 - 15:09 CEST
This incident affected: Internet (Internet Waregem, Internet Woodshop Heule).